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Introduction/Utility
= FrontPage has the tools to make your web site building quick and easy.
= FrontPage lets you skip the tedium of creating your web pages directly in HTML (HyperText
Markup Language), the web’s underlying language. Instead, you use menus and commands similar
to those found in Microsoft’s other applications, such as Word, Excel and PowerPoint.

Pages vs. Webs — What’s the difference?
Page:
= Using the Page command in FrontPage will only design a single webpage.
= Ifyou choose to add images or documents like PDFs to a page, they will have to be stored in web
folders specifically dedicated to these types of files.

Web:

= Choosing Web enables the user to create an entire directory to store and save multiple web pages,
while also creating subdirectories for images and other files. You can view these subdirectories very
easily using many different view options.

= Lets you automatically publish your data to the web right from FrontPage.

= Enables site traffic management.

* Provides easy navigation of pages and files on your website.

= Keeps your website files organized.

Creating Webs
A web places all of your pages into one folder, called a Web folder. Creating a Web allows you to organize
the existing pages you already have, while organizing your images and files into their own folders.

Mew Page or Web

DOpen a page
My Contact, bt
Web Site Templates indese htm
web s | helpsheets.asp To create a new Web
S| @ &N %5 £ TrainingOfferings. asp 1. Open FrontPage: Choose Start - All
= S =] Sl - [= More pages...

owrsce  copems oo o oo | Programs - Microsoft FrontPage.
wWeb Presen...  SupportWeb  Interfa... Specify the |ocation of the new ew . .
i pesndwiss | ) BlankPage 2. Click File > New > Web or Page.
3. In the task pane, click Empty Web.

@] Empty web <

Discussion Empty Wel ork WED Tmsaagl e i Browse,.. !

i If the task pane does not appear
pmeb Shart_ Cescption S automatically, click View = Taskpane.
T e e snennst e n \ 4. Inthe Web Site Templates window, select
Empty Web.
5. Specify a location for the Web.
6. Click OK.

Ok Cancel

Opening a saved Web
1. Choose File > Open Web.
2. Locate the Web and click Open.
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The Views Bar allows you to manage your Web. When you open a Web, this bar will appear at the left of

your screen.
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Page: Use this view to edit and view your webpages.

Folders: Use this view to organize files and folders in your Web.

Reports: Use this view to analyze webpages and manage their contents.

Navigation: Use this view to design the navigation structure for your website.

Hyperlinks: Use this view to view hyperlinks within the website.

Tasks: Use this view to create and manage tasks.

Using Templates

Page Templates |
General IFramas Pages | Style Sheets |
=
g &) @] @] o=
=S =S =S =
Mormal Page  Bibliography  Corfirmation  Feedback Cptions 1
Farm Form I Just add Web task .
ﬁ ,g ,ﬁ ,ﬁ [ Openin current frame 2
o™ 1 1 1 .
Chcl Description
Form Page Frequently  Guest Book Marrow, Create & &d Dody.
Wizard Asked Q... Left-aligy
=
P 7 _—
Marrow, I One-column OneTe ey review 3 .
Right-align. .. y Body with ... Body with... 4
3| 8| 8| & '
S S — S
One-column One-column | Cne-column | One-column
Body with...  Body wit... |Body with Two| Body wit...
Sidehars
8| 8| & &] -

Creating a New Blank Page
1. Click File > New - Web or Page.
2. In the task pane, click Blank Page.

In the task pane, click Page Templates.

In the Page Templates window, select a
template you wish to use (a preview of the
template will display).

Click OK.

Customize your page by replacing the
placeholder text and images with your own.

3. Begin entering the text and images you want on the page.

Using the Views Bar

You can choose among multiple views through the views bar, located at the bottom of the page.

LdMormal [ETHTML CLPreview

= Use the Normal tab to edit a webpage.

= Use the HTML tab to edit the HTML source code for the page.
= Use the Preview tab to see a close approximation of how the webpage looks in Internet Explorer.
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Saving Pages
You should periodically save pages you are working on.

1. Choose File = Save As.
2. File name: Name the page (all one word).
3. Save as type: Web Pages.
4. Save in: save it in the Web folder you created.
5. Click Save.
Folder List x
Creating a Web Folder il C_ﬁ:jﬁf .

You will need to create a Web folder to hold your images and files that you will
be adding to your website.
1. Open the Folder List by choosing View - Folder List.

Imfirnages
: ‘ﬂ wesulogo,gif

index.htm

2. Right-click the folder you want to place the new folder in. Folder List x
3. From the menu, choose New = Folder. The new folder will =03 Ciibocuments and Set
. . [T _private
appear in the Folder List. ) images
4. Right-click on the new folder and select Rename. index.htm
5. Enter a new name for the folder and hit Enter. 1B rycontact. htm

Inserting and Editing Text
You can add, edit, and format text to your pages in the same manner that you would do in MS Word.
1. Click inside the page and start typing.
2. If you do not want images in line with the text on the page, you must use tables. (See section on
Inserting a Table below.)

Creating Numbered and Bulleted Lists
1. Select the text you want to convert to a numbered or bulleted list.
2. Click the Numbering |:=|button on the toolbar to create a numbered list or the Bullets
to create a bulleted list.

= |button

Inserting Clip Art/ Images
To insert a piece of clip art from Microsoft’s collection:
1. Choose Insert > Picture - Clip Art.
2. Inthe task pane, click on Clip Organizer, located towards the bottom of the task pane. The
Microsoft Clip Organizer window will appear.
3. Click on the Office Collections folder. A list of folders will appear by category. Click on a folder
that fits your topic.
4. A selection of clip art will appear. Click on the clip art you want and drag it to your page.

You can also search for specific clip art.
1. In the task pane, enter a clip art search (ex: computer). Click Search.
2. Results will appear. Click on the clip art you wish to insert. It will automatically be inserted onto the
page.
3. If you want to enter another search, click the Modify button and enter another search.

To insert an image from a disk or file on your computer
1. Choose Insert > Picture > From File.
2. Locate the file and click Insert. The image will automatically be placed on your page.
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Resizing an image
1. Click on the image to be resized.
2. Move the mouse cursor over one of the corner handles.
3. When the cursor turns to a double-ended arrow, hold down the mouse button and drag it in or out to
resize the image.
4. Release the mouse button when the image reaches the desired size.

Editing an image
The following shortcuts allow you to edit your images within FrontPage:

Insert Picture from File -I'-" Crop the Image
A Add Text to the Image Line Style
<kl Auto Thumbnail Format Picture
= Position Absolutely E‘? Set Transparent Color to Image
I;h Bring Image Forward @Ml  Change Color Image to Grayscale
IEhl Send Image Backward 4% Bevel the Border of the Image
ib‘ Rotate Image 90 Degrees Left H Resample the Image (after resizing)
= Rotate Image 90 Degrees Right [}|§ Select an Ttem
ﬁ. Flip Image 180 Degrees Horizontal ] Rectangular Hotspot
= Flip Image 180 Degrees Vertical “_*  Circular Hotspot
i ] More Contrast (< Polygonal Hotspot
i Il\fj:ecl;’:tr:ts;ess h Highlight Hotspots
_: G I Less Briglgltness E Restore the Image to its Original Size

Opening an existing HTML document for editing
If you need to edit an existing webpage, you can save the file locally and then open the document in
FrontPage. This allows you to edit the existing features already embedded into the page (ex: layout,
background, images, frames, etc).

1. Choose File 2 Open.

2. Locate the file and click Open.

Creating Web Forms
1. Choose File > New > Page or Web.
Choose Page Templates from the task pane.
Click the General tab and choose Form Page Wizard.
Click OK.
Follow the wizard to set up your form.

ol



Inserting a Table
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Rows & Columns

Layout (Alignment, Border size, Cell
padding, Cell spacing)

Specify Width (In pixels or In percent)
Set as default for new tables

Modify Style

1. Choose Table - Insert > Table.
2. Enter the properties for the table in the Insert Table window.
Insert Table i : =
Size 4/%
Rows: IE ﬂ Calumns: |2 = /
Layout ~
alignment: IDeFauIt vl [V Specify i L—]
o 5 pixels
Border size: II j & In gercent
Cell padding: ID ﬂ _—
Cell spacing: Iﬂ—il
/

mfow/
Skvle, .. 5 | OK

3. Click OK.

Cancel |

Note: To quickly create a table, click the Insert Table = button on the toolbar.

Creating Hyperlinks to Other Web Pages

. - = Insert Hyperlink llll
1' SeleCt the teXt or Slngle CIICk the lmage tO Lirik kot Text to display: IWestarn Connecticut State University ScreenTip... |
which you want to add a hyperlink. ook, [ T & als
2. Select Insert = Hyperlink or click the b bote — ‘% e i (onen) bk |
F%'E; My Conkact. htrn {open)
Insert Hyperlink % button in the L8 et =l
ace in This
Document Browsed |5 Docs Parameters.. .
tOOlbaI'. . . Pages |~ images —_I
3. In the Link to: pane, click on the _ =k |
. . . Create Mew Recent
Existing File or Web Page button. Document | Fles
4. Enter the URL 111 the Addl'eSS ﬁeld or | et v, wesus, edu K2
browse for the URL. EmalAddess Cancel_|
5. Click OK.

Creating Hyperlinks to E-Mail

Insert Hyperlink x| N N N . .
L\nkt Texk to display: |hammershoyt@wesu,edu ScreenTip. .. 1' nghllght the teXt or Slngle CIICk the lmage
o E-mail address: to Wthh you Want tO add an e—mall
Ex\lp\s:gl;g lee;aor Ism:ItuthammershUyt@wcsu edu\ hyperllnk
i 22 \ 2. Select Insert = Hyperlink or click the
ace in This  Recently used e-mail addresses:
e - ] paamecers.. Insert Hyperlink % button.
sse.. |1 3. Inthe Link to: pane, click on the E-Mail
v Address button.
™ 4. Enter the E-mail Address and Subject (if
E-mail Address] applicable) .
Cancel !
5. Click OK.




Preview in Browser

You can see exactly what your webpages will look like by

previewing them in a browser.

1.

ol

You must save all the pages you have open.
Select File = Preview in Browser.

Choose the browser you want to preview your pages in.
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Preview in Browser

2]

Browser

Netscape Mavigator &

add...

Edit, .. |
DEleke |

Set a window size.
Click Preview.

Publishing vour Website

‘Window size
& Defaut ¢ B40x480 ¢ B00xE00 {1024 x 768
[ Automatically save page Preview I Close

Publishing your Web will upload your files to your web space. They will be live on the Internet.

1.
2. Type your publishing address or click the Browse

[98)

Select File > Publish Web.

button to locate your website on a local drive or
file server.

Enter your Web publishing username and password.

A Publish Web window will appear with
checkmarks next to the pages that have beelx

Publish Destination

Enter publish destination:

> Im:p:,l',l'penple.wcsu.edu,l’hammersﬁnyf

Example; http:fisample.microsaft.com

5

updated and will be published.
Click Publish. Your website will
publish and you will get a success
windogw.

Connec\. to

o

people wes

Microsoft FrontPage
User name:

g&j Weh site published succassfully! Password:

Click here ko view vour published web site

Click hete bo view wour publish log file

/

peoplewcsu.edu

1
[l g Browse. ..

If vou do naot have a Web hosting service, find one that supparts
FrontPage by using the Web Presence Provider search page,

Zancel

u,edu

Iﬁ harmmershoyt

[ Remember my password

=1

Cancel

You can view you published website or view your

publish log file.
To just exit, click Done.




Customizing vour Pages
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You can add flare to your website by incorporating some design effects to your pages.

Creating a Page using a Theme Template

A number of colors and graphics themes are available in FrontPage that can be applied to selected pages or

to all pages in your Web.
1. Select the page to which you
want to apply a theme. To

apply the theme to the entire
web (all pages), do not select a

page.

Apply Theme ta:
" all pages
* sSelected page(s)

2. Click Format - Theme.

3. Apply the theme to All pages/ it
or Selected page(s). Ey'Gt

4. Choose a theme from the list. To | |man""

view themes, click on its name
and it will preview in the
Sample of Theme window.

Profile
5. Select the check boxes under the | ™
list to slightly alter the selected N\
theme, lf deSII'ed. l‘r Yivid colors

[v Active graphics

Modular

Mature '\ - g T ] .

I Headinoe vl

= heiork Blitz Llvaiilly 1 Lyt
Passport
Pie Charts
Pixel

Sample of Theme:

|»

—_—

{ Banner

@l Bulletl
© Bullet2
Bullet3

) Ciirla

Fegular Taxt Sample
4] |

o

6' CliCk the MOdify bUtton to alter v Background picture What would you lke ko modify?
Colors, graphics and text. Spply using €55 &cgors... J' Save I Save As.,
7. Cl'lck OK and the theme chosen pie | = | T
will be added to the page(s)
selected.
Creating a Background
1. Open the page you want to add a background to. Page Properties 2x|

2. Select Format > Background.
3. Click the Background tab.

4. You can choose a picture as a background.

OR
5. Choose a colored background.
= Background color

=  Text color

General  Background IMargins I Customl Language I ‘Warkgroup I

Formatking

= Hyperlink colors
=  Get background information form another
page.
6. Click OK.

\

P> [ Background picture
™ siatermath

I Browse, .. Broperties...

[ Enable hypetlink rollover effecks

Rallaver skwle...
Colors
~p Background: I. Automatic T

[— =

> Text:

Active hyperlink:

I. Automatic 'l

[™ @et background information From another page

I Browse. ., |
Ok I

Cancel




Creating a Page Transition Effect Page Transitions d b
1. Opeg ‘Fhe page you want to apply a —_— e —
transition to.
2. Select Format > Page Transition. [Page Enter [] | T =
3. Select an Event from the drop-down list Duration |2— Bow in
that will trigger the transition effect. (seconds): E‘;ﬁlg';'nt
4. Select the transition effect you want to , Circle out
use. Other events.lnclude: Wipe up
. . = Page Exit wipe down
5. Enter the duration of time you want the = Site Enter wipe right
effect to last. = Site Exit Wipe left
6. Click OK. Wertical blinds j
ITI Cancel |
Help
1. Click the Help button, select Microsoft FrontPage Help from the Help menu, or press F1.
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2. Type a topic that you want to learn and click Search.

rwhat would you like to do?

rr".n'ul'hat would you like to do?

' create hyper links

Cptions Search

Dptions Search
.
3. Choose a topic that most rep
4.
5. Click the arrows next to each

topic to find instructions for
topic.

= Show all
Create a hyperlink

In Page view, do one of the Following:

& Create a hvperlink to 2 pane or fils
1. Select either text or a picture,

IF wou do not select text or a
picture, the destination LIRL is
displayed as the hyperlink text,

Click Insert Hyperlink .

Under Link to, click Existing File
or Web Page.

Z
3

4, Select the page or file vou want,
P Create a hyperlink to a new page

I Create a hyperlink to a page or file on
the World Wide Web

P Create a hyperlink to an e-mail
address

P Create a hyperlink to a bookmark.

M,

resents what you want to do.

The following window will open with topics on the task chosen.

l

v

that = Show All
Create a hyperlink A
In Page view, do one of the following:
P Create a hyperlink to a page or file

P Create a hyperlink o a new page

e

'

rr'lul'ul'hat would you like to do?
| S Create a bryperlink

Create a thurmbnail

@ Add 3 button, menu, or

Cormimand

Create a hyperlink o show
a page in anather frame

Display a database value
as a hyperlink

w See more...

P Create a hyperlink to a page or file arf
the World Wide Web

P Create a hyperlink to an e-mail
address

I Create a hyperlink bo a bookmark

You can also click Show
All for instructions on all
topics.

nerlinks

Create by

Options Search

If you would like to learn more about Microsoft FrontPage, please e-mail training@wcsu.edu.
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